Added About page.
[openvpnui.git] / rpm / harbour-openvpn-rig.spec
1 #
2 # Do NOT Edit the Auto-generated Part!
3 # Generated by: spectacle version 0.27
4 #
5
6 Name: harbour-openvpn-rig
7
8 # >> macros
9 # << macros
10
11 %{!?qtc_qmake:%define qtc_qmake %qmake}
12 %{!?qtc_qmake5:%define qtc_qmake5 %qmake5}
13 %{!?qtc_make:%define qtc_make make}
14 %{?qtc_builddir:%define _builddir %qtc_builddir}
15 Summary: OpenVPN User Interface
16 Version: 0.1
17 Release: 1
18 Group: Qt/Qt
19 License: BSD Licence
20 URL: http://example.org/
21 Source0: %{name}-%{version}.tar.bz2
22 Source100: harbour-openvpn-rig.yaml
23 Requires: sailfishsilica-qt5 >= 0.10.9
24 Requires: openvpn >= 2.2.2
25 BuildRequires: pkgconfig(Qt5Quick)
26 BuildRequires: pkgconfig(Qt5Qml)
27 BuildRequires: pkgconfig(Qt5Core)
28 BuildRequires: pkgconfig(sailfishapp) >= 0.0.10
29 BuildRequires: desktop-file-utils
30
31 %description
32 Short description of my SailfishOS Application
33
34
35 %prep
36 %setup -q -n %{name}-%{version}
37
38 # >> setup
39 # << setup
40
41 %build
42 # >> build pre
43 # << build pre
44
45 %qtc_qmake5
46
47 %qtc_make %{?_smp_mflags}
48
49 # >> build post
50 # << build post
51
52 %install
53 rm -rf %{buildroot}
54 # >> install pre
55 # << install pre
56 %qmake5_install
57
58 # >> install post
59 # << install post
60
61 desktop-file-install --delete-original \
62 --dir %{buildroot}%{_datadir}/applications \
63 %{buildroot}%{_datadir}/applications/*.desktop
64
65 %files
66 %defattr(-,root,root,-)
67 %{_bindir}
68 %{_datadir}/%{name}/qml
69 %{_datadir}/applications/%{name}.desktop
70 %{_datadir}/icons/hicolor/86x86/apps/%{name}.png
71 %{_datadir}/%{name}/bin
72 %attr(4755,root,root) %{_datadir}/%{name}/bin/ovpnpermit
73 /usr/bin
74 /usr/share/harbour-openvpn-rig
75 /usr/share/applications
76 /usr/share/icons/hicolor/86x86/apps
77 # >> files
78 # << files