Add graph animation; support for line graphs
[harbour-pedalo.git] / rpm / harbour-pedalo.spec
1 #
2 # Do NOT Edit the Auto-generated Part!
3 # Generated by: spectacle version 0.27
4 #
5
6 Name: harbour-pedalo
7
8 # >> macros
9 # << macros
10
11 %{!?qtc_qmake:%define qtc_qmake %qmake}
12 %{!?qtc_qmake5:%define qtc_qmake5 %qmake5}
13 %{!?qtc_make:%define qtc_make make}
14 %{?qtc_builddir:%define _builddir %qtc_builddir}
15 Summary: Pedalo
16 Version: 0.1
17 Release: 1
18 Group: Qt/Qt
19 License: LICENSE
20 URL: http://www.flypig.co.uk/?to=pedalo
21 Source0: %{name}-%{version}.tar.bz2
22 Source100: harbour-pedalo.yaml
23 Requires: sailfishsilica-qt5 >= 0.10.9
24 BuildRequires: pkgconfig(sailfishapp) >= 1.0.2
25 BuildRequires: pkgconfig(Qt5Core)
26 BuildRequires: pkgconfig(Qt5Qml)
27 BuildRequires: pkgconfig(Qt5Quick)
28 BuildRequires: desktop-file-utils
29
30 %description
31 Measures your relative pedalo performance with others in a privacy-preserving way
32
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 # >> setup
38 # << setup
39
40 %build
41 # >> build pre
42 # << build pre
43
44 %qtc_qmake5
45
46 %qtc_make %{?_smp_mflags}
47
48 # >> build post
49 # << build post
50
51 %install
52 rm -rf %{buildroot}
53 # >> install pre
54 # << install pre
55 %qmake5_install
56
57 # >> install post
58 # << install post
59
60 desktop-file-install --delete-original \
61 --dir %{buildroot}%{_datadir}/applications \
62 %{buildroot}%{_datadir}/applications/*.desktop
63
64 %files
65 %defattr(-,root,root,-)
66 %{_bindir}
67 %{_datadir}/%{name}
68 %{_datadir}/applications/%{name}.desktop
69 %{_datadir}/icons/hicolor/*/apps/%{name}.png
70 # >> files
71 # << files